mirror of https://git.FreeBSD.org/ports.git
games/acm: Remove expired port:
2023-03-31 games/acm: Abandoned upstream. Does not work.
This commit is contained in:
parent
9bc7f181ca
commit
f6dcdbb5e3
1
MOVED
1
MOVED
|
@ -17852,3 +17852,4 @@ devel/horde-whups||2023-03-31|Has expired: Requires php74
|
|||
devel/phpunit6||2023-03-31|Has expired: End of Life since February 1, 2019
|
||||
devel/phpunit7||2023-03-31|Has expired: End of Life since February 7, 2020
|
||||
emulators/pcsxr||2023-03-31|Has expired: Abandoned upstream and no development in 5+ years, consider using games/retroarch
|
||||
games/acm||2023-03-31|Has expired: Abandoned upstream. Does not work.
|
||||
|
|
|
@ -28,7 +28,6 @@
|
|||
SUBDIR += abstreet
|
||||
SUBDIR += abuse_sdl
|
||||
SUBDIR += ace-of-penguins
|
||||
SUBDIR += acm
|
||||
SUBDIR += adonthell
|
||||
SUBDIR += adonthell-wastesedge
|
||||
SUBDIR += aestats
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
PORTNAME= acm
|
||||
PORTVERSION= 5.0
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= # none known
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Aerial combat simulator for X11
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BROKEN= unfetchable
|
||||
DEPRECATED= Abandoned upstream. Does not work.
|
||||
EXPIRATION_DATE= 2023-03-31
|
||||
|
||||
USES= perl5 xorg
|
||||
USE_PERL5= build
|
||||
USE_XORG= x11 xext
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --prefix=${PREFIX} --x-includes=${LOCALBASE}/include \
|
||||
--x-libraries=${LOCALBASE}/lib
|
||||
CONFIGURE_ENV= ac_cv_lib_Xm_XmCreateBulletinBoard=no \
|
||||
ac_cv_lib_gdbm_dbm_fetch=no
|
||||
MAKE_ARGS= prefix=${STAGEDIR}${PREFIX}/ OBVDIR=${STAGEDIR}${DATADIR}/
|
||||
|
||||
# Fix build with clang11
|
||||
CFLAGS+= -fcommon
|
||||
|
||||
OPTIONS_DEFINE= SOUND
|
||||
|
||||
SOUND_LIB_DEPENDS= libaudio.so:audio/nas
|
||||
SOUND_CONFIGURE_ENV_OFF= ac_cv_lib_audio_AuCloseServer=no
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (acm-5.0.tar.gz) = d5c567681b88a1012548f2a98aa88199e83789518b5303ce8053bb4e38dd5b2b
|
||||
SIZE (acm-5.0.tar.gz) = 1218154
|
|
@ -1,16 +0,0 @@
|
|||
--- V/lib/InitAWin.c.orig 1998-08-14 21:09:02 UTC
|
||||
+++ V/lib/InitAWin.c
|
||||
@@ -69,6 +69,13 @@ InitializeX11AWindow(Display * dpy, int screen, Drawab
|
||||
w->csPool1 = (ColorSegment *) malloc(w->CSSize1 * sizeof(ColorSegment));
|
||||
memset(w->csPool1, 0, w->CSSize1 * sizeof(ColorSegment));
|
||||
|
||||
+ // Initialize csPool2 so program doesn't crash later,
|
||||
+ // when trying to free it.
|
||||
+ {
|
||||
+ w->CSSize2 = 0;
|
||||
+ w->csPool2 = (ColorSegment *) NULL;
|
||||
+ }
|
||||
+
|
||||
w->scanLine = (ScanLine *) malloc((w->height + 1) * sizeof(ScanLine));
|
||||
w->lastScanLine = (ScanLine *) malloc((w->height + 1) * sizeof(ScanLine));
|
||||
w->otherLastScanLine = NULL;
|
|
@ -1,189 +0,0 @@
|
|||
--- src/splash.c.orig 1998-08-17 23:45:16.000000000 +0200
|
||||
+++ src/splash.c 2011-12-07 12:30:10.488300879 +0100
|
||||
@@ -31,30 +31,42 @@
|
||||
|
||||
/* xwud - marginally useful raster image undumper */
|
||||
|
||||
+#include <stdlib.h>
|
||||
+#include <stdio.h>
|
||||
+#include <errno.h>
|
||||
+#include <signal.h>
|
||||
|
||||
#include <X11/Xos.h>
|
||||
#include <X11/Xlib.h>
|
||||
#include <X11/Xutil.h>
|
||||
#include <X11/Xatom.h>
|
||||
-#include <stdio.h>
|
||||
#include <X11/XWDFile.h>
|
||||
#define XK_LATIN1
|
||||
#include <X11/keysymdef.h>
|
||||
-#include <errno.h>
|
||||
-#include <signal.h>
|
||||
|
||||
#ifdef X_NOT_STDC_ENV
|
||||
extern int errno;
|
||||
#endif
|
||||
|
||||
-extern char *malloc();
|
||||
unsigned Image_Size();
|
||||
Atom wm_protocols;
|
||||
Atom wm_delete_window;
|
||||
static int split;
|
||||
+void Error();
|
||||
+void putScaledImage();
|
||||
+void putImage();
|
||||
+void Latin1Upper();
|
||||
+void Extract_Plane();
|
||||
+void Do_StdGray();
|
||||
+void Do_StdCol();
|
||||
+void Do_Direct();
|
||||
+void Do_Pseudo();
|
||||
+void _swapshort();
|
||||
+ void _swaplong();
|
||||
|
||||
char *progname;
|
||||
|
||||
+void
|
||||
usage()
|
||||
{
|
||||
fprintf(stderr, "usage: %s [-in <file>] [-noclick] [-geometry <geom>] [-display <display>]\n", progname);
|
||||
@@ -304,7 +316,7 @@
|
||||
Error("Invalid input image header data.");
|
||||
|
||||
/* read in the color map buffer */
|
||||
- if(ncolors = header.ncolors) {
|
||||
+ if((ncolors = header.ncolors)) {
|
||||
colors = (XColor *)malloc((unsigned) ncolors * sizeof(XColor));
|
||||
if (!colors)
|
||||
Error("Can't malloc color table");
|
||||
@@ -658,7 +670,7 @@
|
||||
while ( quit == 0 ) {
|
||||
|
||||
/* wait on mouse input event to terminate */
|
||||
- if (got_event = 0) {
|
||||
+ if (got_event == 0) {
|
||||
sleep (1);
|
||||
}
|
||||
|
||||
@@ -724,6 +736,7 @@
|
||||
return 0;
|
||||
}
|
||||
|
||||
+void
|
||||
putImage (dpy, image_win, gc, out_image, x, y, w, h)
|
||||
Display *dpy;
|
||||
Window image_win;
|
||||
@@ -762,6 +775,7 @@
|
||||
Dimension *width, *height;
|
||||
} Table;
|
||||
|
||||
+void
|
||||
putScaledImage(display, d, gc, src_image, exp_x, exp_y,
|
||||
exp_width, exp_height, dest_width, dest_height)
|
||||
Display* display;
|
||||
@@ -886,13 +900,14 @@
|
||||
XDestroyImage(dest_image);
|
||||
}
|
||||
|
||||
+void
|
||||
Latin1Upper(s)
|
||||
char *s;
|
||||
{
|
||||
unsigned char *str = (unsigned char *)s;
|
||||
unsigned char c;
|
||||
|
||||
- for (; c = *str; str++)
|
||||
+ while ((c = *str++))
|
||||
{
|
||||
if ((c >= XK_a) && (c <= XK_z))
|
||||
*str = c - (XK_a - XK_A);
|
||||
@@ -903,6 +918,7 @@
|
||||
}
|
||||
}
|
||||
|
||||
+void
|
||||
Extract_Plane(in_image, out_image, plane)
|
||||
register XImage *in_image, *out_image;
|
||||
int plane;
|
||||
@@ -925,6 +941,7 @@
|
||||
return vinfo->colormap_size;
|
||||
}
|
||||
|
||||
+int
|
||||
VisualRank(class)
|
||||
int class;
|
||||
{
|
||||
@@ -942,6 +959,7 @@
|
||||
case StaticGray:
|
||||
return 0;
|
||||
}
|
||||
+ return -1;
|
||||
}
|
||||
|
||||
int
|
||||
@@ -956,6 +974,7 @@
|
||||
return (color.green || color.blue);
|
||||
}
|
||||
|
||||
+void
|
||||
Do_StdGray(dpy, stdmap, ncolors, colors, in_image, out_image)
|
||||
Display *dpy;
|
||||
XStandardColormap *stdmap;
|
||||
@@ -971,8 +990,7 @@
|
||||
for (i = 0, color = colors; i < ncolors; i++, color++)
|
||||
color->pixel = stdmap->base_pixel +
|
||||
(((((int)(30L * color->red +
|
||||
- 59L * color->green +
|
||||
- 11L * color->blue) / 100)
|
||||
+ 59L * color->green + 11L * color->blue) / 100)
|
||||
* lim) >> 16) * stdmap->red_mult);
|
||||
for (y = 0; y < in_image->height; y++) {
|
||||
for (x = 0; x < in_image->width; x++) {
|
||||
@@ -984,6 +1002,7 @@
|
||||
|
||||
#define MapVal(val,lim,mult) ((((val * lim) + 32768) / 65535) * mult)
|
||||
|
||||
+void
|
||||
Do_StdCol(dpy, stdmap, ncolors, colors, in_image, out_image)
|
||||
Display *dpy;
|
||||
XStandardColormap *stdmap;
|
||||
@@ -1021,6 +1040,7 @@
|
||||
Error("Visual type is not large enough to hold all colors of the image.");
|
||||
}
|
||||
|
||||
+void
|
||||
Do_Pseudo(dpy, colormap, ncolors, colors, in_image, out_image)
|
||||
Display *dpy;
|
||||
Colormap *colormap;
|
||||
@@ -1048,6 +1068,7 @@
|
||||
}
|
||||
}
|
||||
|
||||
+void
|
||||
Do_Direct(dpy, header, colormap, ncolors, colors, in_image, out_image)
|
||||
Display *dpy;
|
||||
XWDFileHeader *header;
|
||||
@@ -1165,6 +1186,7 @@
|
||||
return((unsigned)image->bytes_per_line * image->height);
|
||||
}
|
||||
|
||||
+void
|
||||
Error(string)
|
||||
char *string;
|
||||
{
|
||||
@@ -1176,6 +1198,7 @@
|
||||
exit(1);
|
||||
}
|
||||
|
||||
+void
|
||||
_swapshort (bp, n)
|
||||
register char *bp;
|
||||
register unsigned n;
|
||||
@@ -1191,6 +1214,7 @@
|
||||
}
|
||||
}
|
||||
|
||||
+void
|
||||
_swaplong (bp, n)
|
||||
register char *bp;
|
||||
register unsigned n;
|
|
@ -1,60 +0,0 @@
|
|||
*** configure~ Mon Aug 17 20:15:13 1998
|
||||
--- configure Mon Feb 1 18:42:53 1999
|
||||
***************
|
||||
*** 529,535 ****
|
||||
|
||||
if test -d /usr/lib/games ; then
|
||||
! OBVDIR="/usr/lib/games/acm"
|
||||
else
|
||||
! OBVDIR=\$\(prefix\)/games/acm
|
||||
fi
|
||||
|
||||
--- 529,535 ----
|
||||
|
||||
if test -d /usr/lib/games ; then
|
||||
! OBVDIR="/usr/lib/games/acm/"
|
||||
else
|
||||
! OBVDIR=\$\(prefix\)/games/acm/
|
||||
fi
|
||||
|
||||
***************
|
||||
*** 557,560 ****
|
||||
--- 557,567 ----
|
||||
fi
|
||||
|
||||
+ # *BSD
|
||||
+ BSD=0
|
||||
+ if uname -s | grep BSD > /dev/null ; then
|
||||
+ BSD=1
|
||||
+ OBVDIR=${prefix}/share/acm/
|
||||
+ fi
|
||||
+
|
||||
# Extract the first word of "gcc", so it can be a program name with args.
|
||||
set dummy gcc; ac_word=$2
|
||||
***************
|
||||
*** 769,773 ****
|
||||
|
||||
|
||||
! if test "$LINUX" = "0" ; then
|
||||
echo $ac_n "checking for elf_end in -lelf""... $ac_c" 1>&6
|
||||
echo "configure:774: checking for elf_end in -lelf" >&5
|
||||
--- 776,780 ----
|
||||
|
||||
|
||||
! if test "$LINUX" = "0" -a "$BSD" = "0"; then
|
||||
echo $ac_n "checking for elf_end in -lelf""... $ac_c" 1>&6
|
||||
echo "configure:774: checking for elf_end in -lelf" >&5
|
||||
***************
|
||||
*** 1129,1133 ****
|
||||
done
|
||||
|
||||
! if test "$LINUX" = "0" ; then
|
||||
ac_safe=`echo "elf.h" | sed 'y%./+-%__p_%'`
|
||||
echo $ac_n "checking for elf.h""... $ac_c" 1>&6
|
||||
--- 1136,1141 ----
|
||||
done
|
||||
|
||||
!
|
||||
! if test "$LINUX" = "0" -a "$BSD" = "0" ; then
|
||||
ac_safe=`echo "elf.h" | sed 'y%./+-%__p_%'`
|
||||
echo $ac_n "checking for elf.h""... $ac_c" 1>&6
|
|
@ -1,25 +0,0 @@
|
|||
--- dis/lib/Makefile.in.orig 1998-12-23 23:35:29.000000000 +0100
|
||||
+++ dis/lib/Makefile.in 2009-03-24 14:16:10.000000000 +0100
|
||||
@@ -63,8 +63,10 @@
|
||||
$(AR) $(ARFLAGS) $@ $(OBJS)
|
||||
$(RANLIB) $@
|
||||
|
||||
-../dis/disp.h dis_xdr.c: dis.x
|
||||
+dis.h: dis.x
|
||||
$(DISGEN) $(srcdir)/dis.x
|
||||
+
|
||||
+../dis/disp.h dis_xdr.c: dis.h
|
||||
mv dis.h ../dis/disp.h
|
||||
mv dis_xdr.c tmp.c
|
||||
perl -p -e 's/\#include "dis.h"/#include <disp.h>/' <tmp.c >dis_xdr.c
|
||||
@@ -84,9 +86,7 @@
|
||||
perl -p -e 's/\#include .*simmgr.*$$/#include "simmgr.h"/' <tmp.c >$@
|
||||
rm -f tmp.c
|
||||
|
||||
-dis_xdr.o: ../dis/dis_xdr.h
|
||||
-
|
||||
-datum_table.o: datumtbl.h
|
||||
+$(OBJS): ../dis/dis_xdr.h ../dis/disp.h datumtbl.h
|
||||
|
||||
datumtbl.h: datumtbl.pl
|
||||
$(PERL) $(srcdir)/datumtbl.pl <$(srcdir)/../dis/datum.h >datumtbl.h
|
|
@ -1,11 +0,0 @@
|
|||
--- dis/test/disscope.c.orig 1998-12-10 23:58:01.000000000 +0100
|
||||
+++ dis/test/disscope.c 2011-06-21 13:01:46.689444826 +0200
|
||||
@@ -172,7 +172,7 @@
|
||||
#endif
|
||||
++ count;
|
||||
}
|
||||
- return;
|
||||
+ return 0;
|
||||
}
|
||||
|
||||
char *
|
|
@ -1,19 +0,0 @@
|
|||
--- dis/data/create-tables-4.orig 1996-01-04 17:20:34 UTC
|
||||
+++ dis/data/create-tables-4
|
||||
@@ -36,7 +36,7 @@ while (<ENTITIES>) {
|
||||
@last_a = @a;
|
||||
|
||||
}
|
||||
-dbmclose (entities);
|
||||
+dbmclose (%entities);
|
||||
close (ENTITIES);
|
||||
|
||||
open (SITES, "./sites");
|
||||
@@ -51,6 +51,6 @@ while (<SITES>) {
|
||||
$sites{$key} = $a[1];
|
||||
}
|
||||
}
|
||||
-dbmclose (sites);
|
||||
+dbmclose (%sites);
|
||||
close (ENTITIES);
|
||||
|
|
@ -1,19 +0,0 @@
|
|||
--- dis/data/create-tables-5.orig 1996-01-04 17:20:40 UTC
|
||||
+++ dis/data/create-tables-5
|
||||
@@ -38,7 +38,7 @@ while (<ENTITIES>) {
|
||||
@last_a = @a;
|
||||
|
||||
}
|
||||
-dbmclose (entities);
|
||||
+dbmclose (%entities);
|
||||
close (ENTITIES);
|
||||
|
||||
open (SITES, "./sites");
|
||||
@@ -53,6 +53,6 @@ while (<SITES>) {
|
||||
$sites{$key} = $a[1];
|
||||
}
|
||||
}
|
||||
-dbmclose (sites);
|
||||
+dbmclose (%sites);
|
||||
close (ENTITIES);
|
||||
|
|
@ -1,19 +0,0 @@
|
|||
--- dis/lib/xdr_var_array.c.orig 1998-05-12 03:58:55 UTC
|
||||
+++ dis/lib/xdr_var_array.c
|
||||
@@ -75,6 +75,7 @@ static char *rcsid = "$Id: xdr_var_array.c,v 1.2 1998/
|
||||
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
+#include <limits.h>
|
||||
#include <rpc/types.h>
|
||||
#include <rpc/xdr.h>
|
||||
|
||||
@@ -104,7 +105,7 @@ xdr_var_array(register XDR * xdrs, caddr_t * addrp, u_
|
||||
register u_int nodesize;
|
||||
|
||||
c = size;
|
||||
- if ((c > maxsize) && (xdrs->x_op != XDR_FREE)) {
|
||||
+ if ((c > maxsize || c > UINT_MAX/elsize) && (xdrs->x_op != XDR_FREE)) {
|
||||
return (FALSE);
|
||||
}
|
||||
nodesize = c * elsize;
|
|
@ -1,14 +0,0 @@
|
|||
--- dis/server/sites.c~ Sat Nov 24 14:46:24 2001
|
||||
+++ dis/server/sites.c Sat Nov 24 14:46:03 2001
|
||||
@@ -27,7 +27,11 @@
|
||||
* README file.
|
||||
*/
|
||||
#include <server.h>
|
||||
+#ifdef HAVE_STDLIB_H
|
||||
+#include <stdlib.h>
|
||||
+#else
|
||||
#include <malloc.h>
|
||||
+#endif
|
||||
#include <string.h>
|
||||
#ifdef HAVE_NDBM
|
||||
#include <ndbm.h>
|
|
@ -1,28 +0,0 @@
|
|||
*** dis/test/Makefile.in~ Fri Aug 14 23:20:24 1998
|
||||
--- dis/test/Makefile.in Mon Feb 1 18:48:38 1999
|
||||
***************
|
||||
*** 1,5 ****
|
||||
srcdir = @srcdir@
|
||||
! VPATH = @srcdir@
|
||||
! CFLAGS = -I$(srcdir)/.. -I.. -I../lib -I$(srcdir)/../../V/lib @CFLAGS@
|
||||
CC = @CC@
|
||||
SRCS = disscope.c simxtest.c tglobe.c
|
||||
--- 1,5 ----
|
||||
srcdir = @srcdir@
|
||||
! VPATH = @srcdir@
|
||||
! CFLAGS = -I$(srcdir)/.. -I.. -I../lib -I$(srcdir)/../../V/lib @CFLAGS@
|
||||
CC = @CC@
|
||||
SRCS = disscope.c simxtest.c tglobe.c
|
||||
***************
|
||||
*** 7,11 ****
|
||||
SIMXTEST_OBJS = simxtest.o
|
||||
TGLOBE_OBJS = tglobe.o
|
||||
! DECOY_OBJS = decoy.o
|
||||
LIBS = -L../lib -ldis -L../../V/lib -lV @LIBS@
|
||||
|
||||
--- 7,11 ----
|
||||
SIMXTEST_OBJS = simxtest.o
|
||||
TGLOBE_OBJS = tglobe.o
|
||||
! DECOY_OBJS = decoy.o
|
||||
LIBS = -L../lib -ldis -L../../V/lib -lV @LIBS@
|
||||
|
|
@ -1,17 +0,0 @@
|
|||
--- src/Makefile.in~ Wed Dec 9 21:53:42 1998
|
||||
+++ src/Makefile.in Sun May 20 10:32:43 2007
|
||||
@@ -17,12 +17,12 @@
|
||||
-I../dis
|
||||
TOPDIR = ..
|
||||
CLEAN_THESE = flight-state black_box_input black_box_output bitmap.h TAGS tags
|
||||
- manext = 1
|
||||
+ manext = 6
|
||||
MAKEDEPEND = makedepend
|
||||
|
||||
PROGRAMS = acm
|
||||
DEFINES = -DSRCDIR=\"$(srcdir)\" -DACM_LIBRARY=\"@OBVDIR@\"
|
||||
- CFLAGS = $(DEFINES) @CFLAGS@ @DEFS@ $(STD_INCLUDES)
|
||||
+ CFLAGS = $(STD_INCLUDES) $(DEFINES) @CFLAGS@ @DEFS@
|
||||
LDFLAGS = @LDFLAGS@
|
||||
SRCS = main.c pm.c gear.c flaps.c drone.c init.c aim9m.c box.c \
|
||||
aim120.c ccip.c \
|
|
@ -1,11 +0,0 @@
|
|||
*** src/acm.man~ Fri Aug 14 16:58:20 1998
|
||||
--- src/acm.man Mon Feb 1 18:05:28 1999
|
||||
***************
|
||||
*** 1,3 ****
|
||||
! .TH ACM l "August 1, 1998"
|
||||
.SH NAME
|
||||
acm \- an aerial combat simulator for X
|
||||
--- 1,3 ----
|
||||
! .TH ACM 6 "October 1, 1995"
|
||||
.SH NAME
|
||||
acm \- an aerial combat simulator for X
|
|
@ -1,14 +0,0 @@
|
|||
--- src/chaser.c~ Tue May 12 05:43:03 1998
|
||||
+++ src/chaser.c Sat Nov 24 14:47:05 2001
|
||||
@@ -20,7 +20,11 @@
|
||||
#include "pm.h"
|
||||
#include <X11/Xutil.h>
|
||||
#include <X11/keysym.h>
|
||||
+#ifdef HAVE_STDLIB_H
|
||||
+#include <stdlib.h>
|
||||
+#else
|
||||
#include <malloc.h>
|
||||
+#endif
|
||||
|
||||
#define MAX_MAPPED_STRING_LEN 20
|
||||
#define MAX_POPUP_STRING_LEN 40
|
|
@ -1,10 +0,0 @@
|
|||
--- src/interpolate.h~ Tue May 12 05:43:04 1998
|
||||
+++ src/interpolate.h Sat May 24 12:03:04 2003
|
||||
@@ -30,6 +30,7 @@
|
||||
*/
|
||||
|
||||
#include <math.h>
|
||||
+#define float_t ACM_float_t
|
||||
|
||||
typedef float float_t;
|
||||
|
|
@ -1,18 +0,0 @@
|
|||
*** src/main.c~ Wed Dec 23 23:29:00 1998
|
||||
--- src/main.c Mon Feb 1 19:14:05 1999
|
||||
***************
|
||||
*** 444,448 ****
|
||||
#endif
|
||||
|
||||
! init(".");
|
||||
|
||||
dpy = XOpenDisplay(display);
|
||||
--- 444,451 ----
|
||||
#endif
|
||||
|
||||
! #ifndef ACM_LIBRARY
|
||||
! #define ACM_LIBRARY "."
|
||||
! #endif
|
||||
! init(ACM_LIBRARY "/");
|
||||
|
||||
dpy = XOpenDisplay(display);
|
|
@ -1,17 +0,0 @@
|
|||
ACM is a LAN-oriented, multiplayer aerial combat simulation. My main
|
||||
design objective was to provide source code that could be easily
|
||||
compiled and executed on a wide variety of platforms. To that end,
|
||||
acm is written entirely in C, exploiting the programming features of
|
||||
Unix, X11, and the BSD socket interface.
|
||||
|
||||
Players engage in air to air combat against one another using heat
|
||||
seeking missiles and cannons.
|
||||
|
||||
ACM is implemented as two programs. The first, named "acm", is a small
|
||||
program that, when invoked, starts a flight session on a given
|
||||
workstation. The second component, named "acms", is a server process
|
||||
that manages the multiplayer environment. It also manages the flight
|
||||
simulation and display management that is required. Most players will
|
||||
prefer to run the acms process on a back-end server system on their
|
||||
local area network. Players at client workstations can then invoke the
|
||||
acm program to begin play.
|
|
@ -1,41 +0,0 @@
|
|||
bin/acm
|
||||
man/man6/acm.6.gz
|
||||
%%DATADIR%%/acmlogo-unix.xwd
|
||||
%%DATADIR%%/aconnon.au
|
||||
%%DATADIR%%/aim9.obv
|
||||
%%DATADIR%%/apglock.au
|
||||
%%DATADIR%%/c172.obv
|
||||
%%DATADIR%%/cannon.au
|
||||
%%DATADIR%%/crash.au
|
||||
%%DATADIR%%/dallas-scene
|
||||
%%DATADIR%%/default-scene
|
||||
%%DATADIR%%/engine.au
|
||||
%%DATADIR%%/f117.dxf
|
||||
%%DATADIR%%/f16.obv
|
||||
%%DATADIR%%/f18.obv
|
||||
%%DATADIR%%/gear_dn.au
|
||||
%%DATADIR%%/gear_up.au
|
||||
%%DATADIR%%/hangar.obv
|
||||
%%DATADIR%%/il78.obv
|
||||
%%DATADIR%%/imarker.au
|
||||
%%DATADIR%%/inventory
|
||||
%%DATADIR%%/kc135.obv
|
||||
%%DATADIR%%/mig23.obv
|
||||
%%DATADIR%%/mig25.obv
|
||||
%%DATADIR%%/mig29.obv
|
||||
%%DATADIR%%/missile.au
|
||||
%%DATADIR%%/mmarker.au
|
||||
%%DATADIR%%/munition-map.txt
|
||||
%%DATADIR%%/object-map.txt
|
||||
%%DATADIR%%/omarker.au
|
||||
%%DATADIR%%/rwr.au
|
||||
%%DATADIR%%/sa10.obv
|
||||
%%DATADIR%%/sa11.obv
|
||||
%%DATADIR%%/sa2.obv
|
||||
%%DATADIR%%/screetch.au
|
||||
%%DATADIR%%/stall.au
|
||||
%%DATADIR%%/su30.obv
|
||||
%%DATADIR%%/surface.obv
|
||||
%%DATADIR%%/telar1.obv
|
||||
%%DATADIR%%/tower.obv
|
||||
%%DATADIR%%/tracer.obv
|
Loading…
Reference in New Issue