math/libdivide: upgrade to v5.2.0

Releases notes at https://github.com/ridiculousfish/libdivide/releases
This commit is contained in:
Thierry Thomas 2025-01-26 17:56:14 +01:00
parent 4d35ce2e53
commit d9540cdf46
3 changed files with 24 additions and 25 deletions

View File

@ -1,11 +1,8 @@
PORTNAME= libdivide
DISTVERSION= 5.0
PORTREVISION= 1
DISTVERSIONPREFIX=v
DISTVERSION= 5.2.0
CATEGORIES= math
PATCH_SITES= https://github.com/ridiculousfish/${PORTNAME}/commit/
PATCHFILES+= fa020f3b3e7ab3e80a2b23ab70bad0f46dbab795.patch:-p1 # https://github.com/ridiculousfish/libdivide/pull/113
MAINTAINER= thierry@FreeBSD.org
COMMENT= Fast prime counting function implementations
WWW= https://libdivide.com/
@ -33,6 +30,6 @@ OPTIONS_DEFINE= NATIVE
NATIVE_CMAKE_BOOL= FREEBSD_NATIVE
do-test:
${CONFIGURE_WRKSRC}/tester
${CONFIGURE_WRKSRC}/OFFtester
.include <bsd.port.mk>

View File

@ -1,5 +1,3 @@
TIMESTAMP = 1731919803
SHA256 (ridiculousfish-libdivide-5.0_GH0.tar.gz) = 01ffdf90bc475e42170741d381eb9cfb631d9d7ddac7337368bcd80df8c98356
SIZE (ridiculousfish-libdivide-5.0_GH0.tar.gz) = 680611
SHA256 (fa020f3b3e7ab3e80a2b23ab70bad0f46dbab795.patch) = 47ed962063ff09c4030a95297803e99b5899795bcaba7630fa3c5e0f80f583dd
SIZE (fa020f3b3e7ab3e80a2b23ab70bad0f46dbab795.patch) = 829
TIMESTAMP = 1737904949
SHA256 (ridiculousfish-libdivide-v5.2.0_GH0.tar.gz) = 73ae910c4cdbda823b7df2c1e0e1e7427464ebc43fc770b1a30bb598cb703f49
SIZE (ridiculousfish-libdivide-v5.2.0_GH0.tar.gz) = 1283521

View File

@ -1,19 +1,23 @@
--- CMakeLists.txt.orig 2021-07-17 18:22:14 UTC
--- CMakeLists.txt.orig 2025-01-25 20:44:54 UTC
+++ CMakeLists.txt
@@ -16,9 +16,9 @@ include(CMakeSanitize)
# Maximum warnings level & warnings as error
add_compile_options(
"$<$<CXX_COMPILER_ID:MSVC>:/W4;/WX>"
- "$<$<CXX_COMPILER_ID:GNU>:-Wall;-Wextra;-pedantic;-Werror>"
- "$<$<CXX_COMPILER_ID:Clang>:-Wall;-Wextra;-pedantic;-Werror>"
- "$<$<CXX_COMPILER_ID:AppleClang>:-Wall;-Wextra;-pedantic;-Werror>"
+ "$<$<CXX_COMPILER_ID:GNU>:-Wall;-Wextra;-pedanticr>"
+ "$<$<CXX_COMPILER_ID:Clang>:-Wall;-Wextra;-pedantic>"
+ "$<$<CXX_COMPILER_ID:AppleClang>:-Wall;-Wextra;-pedantic>"
)
@@ -17,13 +17,13 @@ if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
if (CMAKE_CXX_COMPILER_FRONTEND_VARIANT STREQUAL "MSVC") # clang-cl
add_compile_options("/W4;/WX;")
else() # clang native
- add_compile_options("-Wall;-Wextra;-pedantic;-Werror")
+ add_compile_options("-Wall;-Wextra;-pedantic")
endif()
else()
add_compile_options(
"$<$<CXX_COMPILER_ID:MSVC>:/W4;/WX>"
- "$<$<CXX_COMPILER_ID:GNU>:-Wall;-Wextra;-pedantic;-Werror>"
- "$<$<CXX_COMPILER_ID:AppleClang>:-Wall;-Wextra;-pedantic;-Werror>"
+ "$<$<CXX_COMPILER_ID:GNU>:-Wall;-Wextra;-pedantic>"
+ "$<$<CXX_COMPILER_ID:AppleClang>:-Wall;-Wextra;-pedantic>"
)
endif()
# Build options ################################################
@@ -93,11 +93,10 @@ if (BUILD_TESTS AND NOT CMAKE_CROSSCOMPILING)
@@ -105,11 +105,10 @@ if (LIBDIVIDE_BUILD_TESTS AND NOT CMAKE_CROSSCOMPILING
CPU_ARM_NEON)
if (CPU_X86 OR CPU_ARM_NEON)
cmake_push_check_state()