mirror of https://git.FreeBSD.org/ports.git
net/gupnp-av: Update to 0.14.3
Changes: https://gitlab.gnome.org/GNOME/gupnp-av/-/blob/master/NEWS
This commit is contained in:
parent
cd921f79b9
commit
cb532d7b99
|
@ -1,6 +1,5 @@
|
|||
PORTNAME= gupnp-av
|
||||
PORTVERSION= 0.14.1
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 0.14.3
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= GNOME
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1654708326
|
||||
SHA256 (gupnp-av-0.14.1.tar.xz) = b79ce0cc4b0c66d9c54bc22183a10e5709a0011d2af272025948efcab33a3e4f
|
||||
SIZE (gupnp-av-0.14.1.tar.xz) = 93484
|
||||
TIMESTAMP = 1738088844
|
||||
SHA256 (gupnp-av-0.14.3.tar.xz) = abe2046043e66a9529365d89059be12219c21a4ede0c4743703b0fd9aaf17bb4
|
||||
SIZE (gupnp-av-0.14.3.tar.xz) = 92792
|
||||
|
|
|
@ -1,69 +0,0 @@
|
|||
Obtained from: https://gitlab.gnome.org/GNOME/gupnp-av/-/commit/bff65db081ee1ee5df0a42231ebf8e8fbb27cccf
|
||||
https://gitlab.gnome.org/GNOME/gupnp-av/-/commit/9557768121d54fdcedabe7544863515d6a813354
|
||||
https://gitlab.gnome.org/GNOME/gupnp-av/-/commit/1e10a41fcef6ae0d3e89958db89bc22398f3b4f1
|
||||
|
||||
--- libgupnp-av/gupnp-didl-lite-parser.c.orig 2022-06-03 18:15:12 UTC
|
||||
+++ libgupnp-av/gupnp-didl-lite-parser.c
|
||||
@@ -230,12 +230,17 @@ gupnp_didl_lite_parser_parse_didl_recursive (GUPnPDIDL
|
||||
GUPnPAVXMLDoc *xml_doc = NULL;
|
||||
gboolean result;
|
||||
|
||||
- doc = xmlRecoverMemory (didl, strlen (didl));
|
||||
+ doc = xmlReadMemory (didl,
|
||||
+ strlen (didl),
|
||||
+ NULL,
|
||||
+ NULL,
|
||||
+ XML_PARSE_NONET | XML_PARSE_RECOVER);
|
||||
if (doc == NULL) {
|
||||
g_set_error (error,
|
||||
G_MARKUP_ERROR,
|
||||
G_MARKUP_ERROR_PARSE,
|
||||
- "Could not parse DIDL-Lite XML:\n%s", didl);
|
||||
+ "Could not parse DIDL-Lite XML:\n%s",
|
||||
+ didl);
|
||||
|
||||
return FALSE;
|
||||
}
|
||||
--- libgupnp-av/gupnp-feature-list-parser.c.orig 2022-06-03 18:15:12 UTC
|
||||
+++ libgupnp-av/gupnp-feature-list-parser.c
|
||||
@@ -114,12 +114,17 @@ gupnp_feature_list_parser_parse_text
|
||||
xmlNode *element;
|
||||
GList *feature_list = NULL;
|
||||
|
||||
- doc = xmlRecoverMemory (text, strlen (text));
|
||||
+ doc = xmlReadMemory (text,
|
||||
+ strlen (text),
|
||||
+ NULL,
|
||||
+ NULL,
|
||||
+ XML_PARSE_NONET | XML_PARSE_RECOVER);
|
||||
if (doc == NULL) {
|
||||
g_set_error (error,
|
||||
G_MARKUP_ERROR,
|
||||
G_MARKUP_ERROR_PARSE,
|
||||
- "Could not parse FeatureList XML:\n%s", text);
|
||||
+ "Could not parse FeatureList XML:\n%s",
|
||||
+ text);
|
||||
|
||||
return NULL;
|
||||
}
|
||||
--- libgupnp-av/xml-util.h.orig 2022-06-03 18:15:12 UTC
|
||||
+++ libgupnp-av/xml-util.h
|
||||
@@ -16,6 +16,7 @@
|
||||
|
||||
#include <glib.h>
|
||||
#include <libxml/tree.h>
|
||||
+#include <libxml/parser.h>
|
||||
#include <stdarg.h>
|
||||
#include <glib-object.h>
|
||||
|
||||
--- meson.build.orig 2022-06-03 18:15:12 UTC
|
||||
+++ meson.build
|
||||
@@ -71,7 +71,7 @@ endif
|
||||
|
||||
common_cflags = cc.get_supported_arguments(test_cflags)
|
||||
|
||||
-add_project_arguments(cc.get_supported_arguments('-Werror=deprecated-declarations'), language: 'c')
|
||||
+#add_project_arguments(cc.get_supported_arguments('-Werror=deprecated-declarations'), language: 'c')
|
||||
conf = configuration_data()
|
||||
conf.set_quoted('DATADIR', join_paths(get_option('prefix'), get_option('datadir'), 'gupnp-av'))
|
||||
conf.set_quoted('VERSION', meson.project_version())
|
|
@ -1,17 +0,0 @@
|
|||
Obtained from: https://gitlab.gnome.org/GNOME/gupnp-av/-/commit/767388bc16e08d4e1e1f419555165cc1816be931
|
||||
|
||||
--- meson.build.orig 2022-06-03 18:15:12 UTC
|
||||
+++ meson.build
|
||||
@@ -87,6 +87,12 @@ subdir('data')
|
||||
pkg = import('pkgconfig')
|
||||
pkg.generate(
|
||||
gupnp_av_lib,
|
||||
+ requires : [
|
||||
+ 'glib-2.0',
|
||||
+ 'gobject-2.0',
|
||||
+ 'gio-2.0',
|
||||
+ 'libxml-2.0'
|
||||
+ ],
|
||||
subdirs : 'gupnp-av-1.0',
|
||||
description : 'GObject-based AV specific UPnP library'
|
||||
)
|
|
@ -22,7 +22,7 @@ lib/girepository-1.0/GUPnPAV-1.0.typelib
|
|||
lib/libgupnp-av-1.0.a
|
||||
lib/libgupnp-av-1.0.so
|
||||
lib/libgupnp-av-1.0.so.3
|
||||
lib/libgupnp-av-1.0.so.3.14.1
|
||||
lib/libgupnp-av-1.0.so.3.14.3
|
||||
libdata/pkgconfig/gupnp-av-1.0.pc
|
||||
share/gir-1.0/GUPnPAV-1.0.gir
|
||||
%%DATADIR%%/av.xsd
|
||||
|
|
Loading…
Reference in New Issue