math/or-tools: update 9.8 → 9.12-20250219

This commit is contained in:
Yuri Victorovich 2025-02-20 08:43:01 -08:00
parent c815bf676a
commit 81593f99c2
7 changed files with 204 additions and 140 deletions

View File

@ -1,6 +1,7 @@
PORTNAME= openroad
DISTVERSIONPREFIX= v
DISTVERSION= 2.0-20250216
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= cad

View File

@ -1,6 +1,6 @@
PORTNAME= minizinc-solvers
PORTVERSION= 20210505
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org

View File

@ -1,7 +1,6 @@
PORTNAME= or-tools
DISTVERSIONPREFIX= v
DISTVERSION= 9.8
PORTREVISION= 8
DISTVERSION= 9.12-20250219 # tag from the 'main' branch
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@ -12,6 +11,8 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
PATCH_DEPENDS= gsed:textproc/gsed
xBUILD_DEPENDS= benchmark>0:devel/benchmark \
googletest>0:devel/googletest
LIB_DEPENDS= libabsl_base.so:devel/abseil \
libCbc.so:math/cbc \
libCgl.so:math/cgl \
@ -20,21 +21,29 @@ LIB_DEPENDS= libabsl_base.so:devel/abseil \
libCoinUtils.so:math/coinutils \
libgflags.so:devel/gflags \
libglog.so:devel/glog \
libhighs.so:math/highs \
libnauty.so:math/nauty \
libopenblas.so:math/openblas \
libOsi.so:math/osi \
libOsiClp.so:math/clp \
libprotobuf.so:devel/protobuf \
libre2.so:devel/re2
libre2.so:devel/re2 \
libscip.so:math/SCIP
TEST_DEPENDS= googletest>0:devel/googletest
USES= blaslapack cmake:testing compiler:c++17-lang eigen:3 pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= google
USE_LDCONFIG= yes
CMAKE_OFF= BUILD_PYTHON BUILD_DEPS INSTALL_BUILD_DEPS BUILD_EXAMPLES BUILD_SAMPLES
CMAKE_ON= BUILD_CXX
CMAKE_TESTING_ON= BUILD_EXAMPLES BUILD_CXX_EXAMPLES
USE_GITHUB= yes
GH_ACCOUNT= google
GH_TAGNAME= e0f2787c5050c7cf6bc3e5f902fdb8fc11bd3f38 # tag from the 'main' branch (as opposedto 'stable' branch) that includes the fix for https://github.com/google/or-tools/issues/4548
CMAKE_OFF= BUILD_PYTHON BUILD_DEPS INSTALL_BUILD_DEPS \
BUILD_TESTING BUILD_EXAMPLES BUILD_SAMPLES
CMAKE_ON= BUILD_CXX \
USE_PDLP \
USE_SCIP
CMAKE_TESTING_ON= BUILD_TESTING BUILD_EXAMPLES BUILD_CXX_EXAMPLES
CONFIGURE_ENV= UNIX_CBC_DIR=${LOCALBASE} UNIX_CLP_DIR=${LOCALBASE}
@ -52,12 +61,15 @@ SCIP_LIB_DEPENDS= libscip.so:math/SCIP
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/-//}
PORTDOCS= *
# 3 tests are known to fail, see https://github.com/google/or-tools/issues/3429
post-patch:
@${REINPLACE_CMD} -e '17,19d' ${WRKSRC}/ortools/base/logging.h
post-install:
@${FIND} ${STAGEDIR}${PREFIX} -type d -empty -delete
# tests as of 9.12-20250219: 97% tests passed, 5 tests failed out of 163:
# Tests cxx_cpp_linear_programming and cxx_cpp_integer_programming abort: https://github.com/google/or-tools/issues/4555
# 13 tests fail whuke running the math_opt_solvers_cp_sat_solver_test test executable: https://github.com/google/or-tools/issues/4556
# The test SimpleMaxFlowTest.ProblematicProblemWithMaxCapacity (graph_max_flow_test) fails to find test data when it is built outsource: https://github.com/google/or-tools/issues/4557
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1699869085
SHA256 (google-or-tools-v9.8_GH0.tar.gz) = 85e10e7acf0a9d9a3b891b9b108f76e252849418c6230daea94ac429af8a4ea4
SIZE (google-or-tools-v9.8_GH0.tar.gz) = 19725471
TIMESTAMP = 1739999958
SHA256 (google-or-tools-v9.12-20250219-e0f2787c5050c7cf6bc3e5f902fdb8fc11bd3f38_GH0.tar.gz) = 681c1cc3ebb6c9cc364bc0d9930e299a838319b6aae02355a386e751776d11a2
SIZE (google-or-tools-v9.12-20250219-e0f2787c5050c7cf6bc3e5f902fdb8fc11bd3f38_GH0.tar.gz) = 21136421

View File

@ -1,14 +0,0 @@
--- ortools/util/zvector.h.orig 2020-07-20 23:36:37 UTC
+++ ortools/util/zvector.h
@@ -17,7 +17,11 @@
#if defined(__APPLE__) && defined(__GNUC__)
#include <machine/endian.h>
#elif !defined(_MSC_VER)
+#if defined(__FreeBSD__)
+#include <sys/endian.h>
+#else
#include <endian.h>
+#endif
#endif
#include <climits>
#include <cstdio>

View File

@ -1,46 +0,0 @@
--- ortools/base/file.cc.orig 2023-11-13 09:51:25 UTC
+++ ortools/base/file.cc
@@ -224,7 +224,8 @@ class NoOpErrorCollector : public google::protobuf::io
namespace {
class NoOpErrorCollector : public google::protobuf::io::ErrorCollector {
public:
- void AddError(int line, int column, const std::string& message) override {}
+ void RecordError(int /*line*/, int /*column*/,
+ absl::string_view /*message*/) override {}
};
} // namespace
--- ortools/util/file_util.cc.orig 2023-11-13 09:51:25 UTC
+++ ortools/util/file_util.cc
@@ -137,7 +137,7 @@ bool WriteProtoToFile(absl::string_view filename,
case ProtoWriteFormat::kJson: {
google::protobuf::util::JsonPrintOptions options;
options.add_whitespace = true;
- options.always_print_primitive_fields = true;
+ options.always_print_fields_with_no_presence = true;
options.preserve_proto_field_names = true;
if (!google::protobuf::util::MessageToJsonString(proto, &output_string,
options)
--- ortools/util/parse_proto.cc.orig 2023-11-13 09:51:25 UTC
+++ ortools/util/parse_proto.cc
@@ -36,11 +36,16 @@ class TextFormatErrorCollector : public google::protob
TextFormatErrorCollector() = default;
~TextFormatErrorCollector() override = default;
- void AddError(int line, int column, const std::string& message) override {
- collected_errors_.push_back({false, line, column, message});
+ void RecordError(const int line, const int column,
+ absl::string_view message) override {
+ collected_errors_.push_back(
+ {/*warning=*/false, line, column, std::string(message)});
}
- void AddWarning(int line, int column, const std::string& message) override {
- collected_errors_.push_back({true, line, column, message});
+
+ void RecordWarning(const int line, const int column,
+ absl::string_view message) override {
+ collected_errors_.push_back(
+ {/*warning=*/true, line, column, std::string(message)});
}
// Returns a string listing each collected error. When an error is associated

View File

@ -1,6 +1,8 @@
%%FLATZINC%%bin/fzn-cp-sat
bin/sat_runner
bin/solve
bin/vector_bin_packing
include/ortools/algorithms/adjustable_k_ary_heap.h
include/ortools/algorithms/binary_indexed_tree.h
include/ortools/algorithms/binary_search.h
include/ortools/algorithms/dense_doubly_linked_list.h
@ -10,13 +12,9 @@ include/ortools/algorithms/dynamic_permutation.h
include/ortools/algorithms/find_graph_symmetries.h
include/ortools/algorithms/hungarian.h
include/ortools/algorithms/knapsack_solver.h
include/ortools/algorithms/knapsack_solver_for_cuts.h
include/ortools/algorithms/n_choose_k.h
include/ortools/algorithms/python/knapsack_solver_doc.h
include/ortools/algorithms/set_cover.h
include/ortools/algorithms/set_cover_ledger.h
include/ortools/algorithms/set_cover_model.h
include/ortools/algorithms/set_cover_reader.h
include/ortools/algorithms/set_cover_utils.h
include/ortools/algorithms/radix_sort.h
include/ortools/algorithms/sparse_permutation.h
include/ortools/base/accurate_sum.h
include/ortools/base/adjustable_priority_queue-inl.h
@ -25,14 +23,16 @@ include/ortools/base/base_export.h
include/ortools/base/basictypes.h
include/ortools/base/bitmap.h
include/ortools/base/case.h
include/ortools/base/cleanup.h
include/ortools/base/commandlineflags.h
include/ortools/base/constant_divisor.h
include/ortools/base/container_logging.h
include/ortools/base/dump_vars.h
include/ortools/base/dynamic_library.h
include/ortools/base/encodingutils.h
include/ortools/base/file.h
include/ortools/base/filesystem.h
include/ortools/base/fuzztest.h
include/ortools/base/gmock.h
include/ortools/base/gzipfile.h
include/ortools/base/gzipstring.h
include/ortools/base/hash.h
@ -46,11 +46,16 @@ include/ortools/base/macros.h
include/ortools/base/map_util.h
include/ortools/base/mathutil.h
include/ortools/base/memfile.h
include/ortools/base/memutil.h
include/ortools/base/message_matchers.h
include/ortools/base/murmur.h
include/ortools/base/mutable_memfile.h
include/ortools/base/numbers.h
include/ortools/base/options.h
include/ortools/base/parse_test_proto.h
include/ortools/base/parse_text_proto.h
include/ortools/base/path.h
include/ortools/base/proto_enum_utils.h
include/ortools/base/protobuf_util.h
include/ortools/base/protoutil.h
include/ortools/base/ptr_util.h
@ -60,19 +65,20 @@ include/ortools/base/small_map.h
include/ortools/base/source_location.h
include/ortools/base/status_builder.h
include/ortools/base/status_macros.h
include/ortools/base/status_matchers.h
include/ortools/base/stl_logging.h
include/ortools/base/stl_util.h
include/ortools/base/strong_int.h
include/ortools/base/strong_vector.h
include/ortools/base/strtoint.h
include/ortools/base/sysinfo.h
include/ortools/base/temp_path.h
include/ortools/base/threadpool.h
include/ortools/base/timer.h
include/ortools/base/top_n.h
include/ortools/base/typeid.h
include/ortools/base/types.h
include/ortools/base/version.h
include/ortools/base/vlog.h
include/ortools/base/vlog_is_on.h
include/ortools/base/zipfile.h
include/ortools/bop/bop_base.h
include/ortools/bop/bop_fs.h
@ -91,20 +97,7 @@ include/ortools/constraint_solver/constraint_solver.h
include/ortools/constraint_solver/constraint_solveri.h
include/ortools/constraint_solver/demon_profiler.pb.h
include/ortools/constraint_solver/java/javawrapcp_util.h
include/ortools/constraint_solver/routing.h
include/ortools/constraint_solver/routing_constraints.h
include/ortools/constraint_solver/routing_decision_builders.h
include/ortools/constraint_solver/routing_enums.pb.h
include/ortools/constraint_solver/routing_filters.h
include/ortools/constraint_solver/routing_index_manager.h
include/ortools/constraint_solver/routing_insertion_lns.h
include/ortools/constraint_solver/routing_lp_scheduling.h
include/ortools/constraint_solver/routing_neighborhoods.h
include/ortools/constraint_solver/routing_parameters.h
include/ortools/constraint_solver/routing_parameters.pb.h
include/ortools/constraint_solver/routing_search.h
include/ortools/constraint_solver/routing_types.h
include/ortools/constraint_solver/routing_utils.h
include/ortools/constraint_solver/python/constraint_solver_doc.h
include/ortools/constraint_solver/search_limit.pb.h
include/ortools/constraint_solver/search_stats.pb.h
include/ortools/constraint_solver/solver_parameters.pb.h
@ -113,7 +106,6 @@ include/ortools/flatzinc/cp_model_fz_solver.h
include/ortools/flatzinc/model.h
include/ortools/flatzinc/parser.h
include/ortools/flatzinc/parser_util.h
include/ortools/flatzinc/presolve.h
include/ortools/glop/basis_representation.h
include/ortools/glop/dual_edge_norms.h
include/ortools/glop/entering_variable.h
@ -137,26 +129,38 @@ include/ortools/glpk/glpk_computational_form.h
include/ortools/glpk/glpk_env_deleter.h
include/ortools/glpk/glpk_formatters.h
include/ortools/graph/assignment.h
include/ortools/graph/bfs.h
include/ortools/graph/bidirectional_dijkstra.h
include/ortools/graph/bounded_dijkstra.h
include/ortools/graph/christofides.h
include/ortools/graph/cliques.h
include/ortools/graph/connected_components.h
include/ortools/graph/dag_constrained_shortest_path.h
include/ortools/graph/dag_shortest_path.h
include/ortools/graph/ebert_graph.h
include/ortools/graph/eulerian_path.h
include/ortools/graph/flow_graph.h
include/ortools/graph/flow_problem.pb.h
include/ortools/graph/generic_max_flow.h
include/ortools/graph/graph.h
include/ortools/graph/graphs.h
include/ortools/graph/graph_io.h
include/ortools/graph/hamiltonian_path.h
include/ortools/graph/io.h
include/ortools/graph/iterators.h
include/ortools/graph/k_shortest_paths.h
include/ortools/graph/line_graph.h
include/ortools/graph/linear_assignment.h
include/ortools/graph/max_flow.h
include/ortools/graph/min_cost_flow.h
include/ortools/graph/minimum_spanning_tree.h
include/ortools/graph/minimum_vertex_cover.h
include/ortools/graph/multi_dijkstra.h
include/ortools/graph/one_tree_lower_bound.h
include/ortools/graph/perfect_matching.h
include/ortools/graph/random_graph.h
include/ortools/graph/rooted_tree.h
include/ortools/graph/shortest_paths.h
include/ortools/graph/strongly_connected_components.h
include/ortools/graph/test_util.h
include/ortools/graph/topologicalsorter.h
include/ortools/graph/util.h
include/ortools/gscip/gscip.h
@ -169,6 +173,9 @@ include/ortools/gscip/gscip_message_handler.h
include/ortools/gscip/gscip_parameters.h
include/ortools/gscip/legacy_scip_params.h
include/ortools/gurobi/environment.h
include/ortools/gurobi/gurobi_stdout_matchers.h
include/ortools/gurobi/gurobi_util.h
include/ortools/gurobi/isv_public/gurobi_isv.h
include/ortools/init/init.h
include/ortools/init/python/init_doc.h
include/ortools/linear_solver/glop_utils.h
@ -179,14 +186,19 @@ include/ortools/linear_solver/linear_solver_callback.h
include/ortools/linear_solver/model_exporter.h
include/ortools/linear_solver/model_exporter_swig_helper.h
include/ortools/linear_solver/model_validator.h
include/ortools/linear_solver/proto_solver/glop_proto_solver.h
include/ortools/linear_solver/proto_solver/gurobi_proto_solver.h
include/ortools/linear_solver/proto_solver/highs_proto_solver.h
include/ortools/linear_solver/proto_solver/pdlp_proto_solver.h
include/ortools/linear_solver/proto_solver/proto_utils.h
include/ortools/linear_solver/proto_solver/sat_proto_solver.h
include/ortools/linear_solver/proto_solver/sat_solver_utils.h
include/ortools/linear_solver/proto_solver/scip_proto_solver.h
include/ortools/linear_solver/proto_solver/xpress_proto_solver.h
include/ortools/linear_solver/samples/network_design_ilph.h
include/ortools/linear_solver/scip_callback.h
include/ortools/linear_solver/scip_helper_macros.h
include/ortools/linear_solver/solve_mp_model.h
include/ortools/linear_solver/wrappers/model_builder_helper.h
include/ortools/lp_data/lp_data.h
include/ortools/lp_data/lp_data_utils.h
@ -225,6 +237,7 @@ include/ortools/math_opt/constraints/sos/util.h
include/ortools/math_opt/constraints/sos/validator.h
include/ortools/math_opt/constraints/util/model_util.h
include/ortools/math_opt/core/arrow_operator_proxy.h
include/ortools/math_opt/core/base_solver.h
include/ortools/math_opt/core/c_api/solver.h
include/ortools/math_opt/core/concurrent_calls_guard.h
include/ortools/math_opt/core/empty_bounds.h
@ -233,10 +246,10 @@ include/ortools/math_opt/core/inverted_bounds.h
include/ortools/math_opt/core/math_opt_proto_utils.h
include/ortools/math_opt/core/model_summary.h
include/ortools/math_opt/core/non_streamable_solver_init_arguments.h
include/ortools/math_opt/core/solve_interrupter.h
include/ortools/math_opt/core/solver.h
include/ortools/math_opt/core/solver_debug.h
include/ortools/math_opt/core/solver_interface.h
include/ortools/math_opt/core/sorted.h
include/ortools/math_opt/core/sparse_submatrix.h
include/ortools/math_opt/core/sparse_vector.h
include/ortools/math_opt/core/sparse_vector_view.h
@ -246,9 +259,11 @@ include/ortools/math_opt/cpp/compute_infeasible_subsystem_arguments.h
include/ortools/math_opt/cpp/compute_infeasible_subsystem_result.h
include/ortools/math_opt/cpp/enums.h
include/ortools/math_opt/cpp/formatters.h
include/ortools/math_opt/cpp/incremental_solver.h
include/ortools/math_opt/cpp/key_types.h
include/ortools/math_opt/cpp/linear_constraint.h
include/ortools/math_opt/cpp/map_filter.h
include/ortools/math_opt/cpp/matchers.h
include/ortools/math_opt/cpp/math_opt.h
include/ortools/math_opt/cpp/message_callback.h
include/ortools/math_opt/cpp/model.h
@ -258,8 +273,10 @@ include/ortools/math_opt/cpp/parameters.h
include/ortools/math_opt/cpp/solution.h
include/ortools/math_opt/cpp/solve.h
include/ortools/math_opt/cpp/solve_arguments.h
include/ortools/math_opt/cpp/solve_impl.h
include/ortools/math_opt/cpp/solve_result.h
include/ortools/math_opt/cpp/solver_init_arguments.h
include/ortools/math_opt/cpp/solver_resources.h
include/ortools/math_opt/cpp/sparse_containers.h
include/ortools/math_opt/cpp/statistics.h
include/ortools/math_opt/cpp/streamable_solver_init_arguments.h
@ -267,10 +284,15 @@ include/ortools/math_opt/cpp/update_result.h
include/ortools/math_opt/cpp/update_tracker.h
include/ortools/math_opt/cpp/variable_and_expressions.h
include/ortools/math_opt/infeasible_subsystem.pb.h
include/ortools/math_opt/io/lp/lp_model.h
include/ortools/math_opt/io/lp/lp_name.h
include/ortools/math_opt/io/lp/model_utils.h
include/ortools/math_opt/io/lp_converter.h
include/ortools/math_opt/io/lp_parser.h
include/ortools/math_opt/io/mps_converter.h
include/ortools/math_opt/io/names_removal.h
include/ortools/math_opt/io/proto_converter.h
include/ortools/math_opt/labs/dualizer.h
include/ortools/math_opt/labs/general_constraint_to_mip.h
include/ortools/math_opt/labs/linear_expr_util.h
include/ortools/math_opt/labs/solution_feasibility_checker.h
@ -280,8 +302,29 @@ include/ortools/math_opt/model_parameters.pb.h
include/ortools/math_opt/model_update.pb.h
include/ortools/math_opt/parameters.pb.h
include/ortools/math_opt/result.pb.h
include/ortools/math_opt/samples/branch_and_bound.h
include/ortools/math_opt/rpc.pb.h
include/ortools/math_opt/solution.pb.h
include/ortools/math_opt/solver_tests/base_solver_test.h
include/ortools/math_opt/solver_tests/callback_tests.h
include/ortools/math_opt/solver_tests/generic_tests.h
include/ortools/math_opt/solver_tests/infeasible_subsystem_tests.h
include/ortools/math_opt/solver_tests/invalid_input_tests.h
include/ortools/math_opt/solver_tests/ip_model_solve_parameters_tests.h
include/ortools/math_opt/solver_tests/ip_multiple_solutions_tests.h
include/ortools/math_opt/solver_tests/ip_parameter_tests.h
include/ortools/math_opt/solver_tests/logical_constraint_tests.h
include/ortools/math_opt/solver_tests/lp_incomplete_solve_tests.h
include/ortools/math_opt/solver_tests/lp_initial_basis_tests.h
include/ortools/math_opt/solver_tests/lp_model_solve_parameters_tests.h
include/ortools/math_opt/solver_tests/lp_parameter_tests.h
include/ortools/math_opt/solver_tests/lp_tests.h
include/ortools/math_opt/solver_tests/mip_tests.h
include/ortools/math_opt/solver_tests/multi_objective_tests.h
include/ortools/math_opt/solver_tests/qc_tests.h
include/ortools/math_opt/solver_tests/qp_tests.h
include/ortools/math_opt/solver_tests/second_order_cone_tests.h
include/ortools/math_opt/solver_tests/status_tests.h
include/ortools/math_opt/solver_tests/test_models.h
include/ortools/math_opt/solvers/cp_sat_solver.h
include/ortools/math_opt/solvers/glop_solver.h
include/ortools/math_opt/solvers/glpk.pb.h
@ -289,15 +332,21 @@ include/ortools/math_opt/solvers/glpk/gap.h
include/ortools/math_opt/solvers/glpk/glpk_sparse_vector.h
include/ortools/math_opt/solvers/glpk/rays.h
include/ortools/math_opt/solvers/glpk_solver.h
include/ortools/math_opt/solvers/gscip/gscip_solver_constraint_handler.h
include/ortools/math_opt/solvers/gscip_solver.h
include/ortools/math_opt/solvers/gscip_solver_callback.h
include/ortools/math_opt/solvers/gurobi.pb.h
include/ortools/math_opt/solvers/gurobi/g_gurobi.h
include/ortools/math_opt/solvers/gurobi_callback.h
include/ortools/math_opt/solvers/gurobi_init_arguments.h
include/ortools/math_opt/solvers/gurobi_solver.h
include/ortools/math_opt/solvers/highs.pb.h
include/ortools/math_opt/solvers/highs_solver.h
include/ortools/math_opt/solvers/message_callback_data.h
include/ortools/math_opt/solvers/osqp.pb.h
include/ortools/math_opt/solvers/pdlp_bridge.h
include/ortools/math_opt/solvers/pdlp_solver.h
include/ortools/math_opt/solvers/xpress/g_xpress.h
include/ortools/math_opt/solvers/xpress_solver.h
include/ortools/math_opt/sparse_containers.pb.h
include/ortools/math_opt/storage/atomic_constraint_storage.h
include/ortools/math_opt/storage/iterators.h
@ -307,11 +356,12 @@ include/ortools/math_opt/storage/model_storage.h
include/ortools/math_opt/storage/model_storage_types.h
include/ortools/math_opt/storage/objective_storage.h
include/ortools/math_opt/storage/range.h
include/ortools/math_opt/storage/sorted.h
include/ortools/math_opt/storage/sparse_coefficient_map.h
include/ortools/math_opt/storage/sparse_matrix.h
include/ortools/math_opt/storage/update_trackers.h
include/ortools/math_opt/storage/variable_storage.h
include/ortools/math_opt/testing/param_name.h
include/ortools/math_opt/testing/stream.h
include/ortools/math_opt/tools/file_format_flags.h
include/ortools/math_opt/validators/bounds_and_status_validator.h
include/ortools/math_opt/validators/callback_validator.h
@ -338,6 +388,7 @@ include/ortools/pdlp/iteration_stats.h
include/ortools/pdlp/primal_dual_hybrid_gradient.h
include/ortools/pdlp/quadratic_program.h
include/ortools/pdlp/quadratic_program_io.h
include/ortools/pdlp/scheduler.h
include/ortools/pdlp/sharded_optimization_utils.h
include/ortools/pdlp/sharded_quadratic_program.h
include/ortools/pdlp/sharder.h
@ -349,38 +400,74 @@ include/ortools/pdlp/test_util.h
include/ortools/pdlp/trust_region.h
include/ortools/port/file.h
include/ortools/port/proto_utils.h
include/ortools/port/scoped_std_stream_capture.h
include/ortools/port/sysinfo.h
include/ortools/port/utf8.h
include/ortools/routing/carp_parser.h
include/ortools/routing/cvrptw_lib.h
include/ortools/routing/nearp_parser.h
include/ortools/routing/pdtsp_parser.h
include/ortools/routing/simple_graph.h
include/ortools/routing/solomon_parser.h
include/ortools/routing/solution_serializer.h
include/ortools/routing/tsplib_parser.h
include/ortools/routing/tsptw_parser.h
include/ortools/routing/constraints.h
include/ortools/routing/decision_builders.h
include/ortools/routing/enums.pb.h
include/ortools/routing/filter_committables.h
include/ortools/routing/filters.h
include/ortools/routing/ils.h
include/ortools/routing/ils.pb.h
include/ortools/routing/index_manager.h
include/ortools/routing/insertion_lns.h
include/ortools/routing/lp_scheduling.h
include/ortools/routing/neighborhoods.h
include/ortools/routing/parameters.h
include/ortools/routing/parameters.pb.h
include/ortools/routing/parameters_utils.h
include/ortools/routing/parsers/capacity_planning.pb.h
include/ortools/routing/parsers/carp_parser.h
include/ortools/routing/parsers/cvrptw_lib.h
include/ortools/routing/parsers/dow_parser.h
include/ortools/routing/parsers/lilim_parser.h
include/ortools/routing/parsers/nearp_parser.h
include/ortools/routing/parsers/pdtsp_parser.h
include/ortools/routing/parsers/simple_graph.h
include/ortools/routing/parsers/solomon_parser.h
include/ortools/routing/parsers/solution_serializer.h
include/ortools/routing/parsers/tsplib_parser.h
include/ortools/routing/parsers/tsptw_parser.h
include/ortools/routing/python/doc.h
include/ortools/routing/python/index_manager_doc.h
include/ortools/routing/python/parameters_doc.h
include/ortools/routing/routing.h
include/ortools/routing/search.h
include/ortools/routing/types.h
include/ortools/routing/utils.h
include/ortools/sat/2d_mandatory_overlap_propagator.h
include/ortools/sat/2d_orthogonal_packing.h
include/ortools/sat/2d_orthogonal_packing_testing.h
include/ortools/sat/2d_packing_brute_force.h
include/ortools/sat/2d_rectangle_presolve.h
include/ortools/sat/2d_try_edge_propagator.h
include/ortools/sat/all_different.h
include/ortools/sat/boolean_problem.h
include/ortools/sat/boolean_problem.pb.h
include/ortools/sat/c_api/cp_solver_c.h
include/ortools/sat/circuit.h
include/ortools/sat/clause.h
include/ortools/sat/combine_solutions.h
include/ortools/sat/constraint_violation.h
include/ortools/sat/cp_constraints.h
include/ortools/sat/cp_model.h
include/ortools/sat/cp_model.pb.h
include/ortools/sat/cp_model_checker.h
include/ortools/sat/cp_model_copy.h
include/ortools/sat/cp_model_expand.h
include/ortools/sat/cp_model_lns.h
include/ortools/sat/cp_model_loader.h
include/ortools/sat/cp_model_mapping.h
include/ortools/sat/cp_model_objective.h
include/ortools/sat/cp_model_postsolve.h
include/ortools/sat/cp_model_presolve.h
include/ortools/sat/cp_model_search.h
include/ortools/sat/cp_model_service.pb.h
include/ortools/sat/cp_model_solver.h
include/ortools/sat/cp_model_solver_helpers.h
include/ortools/sat/cp_model_symmetries.h
include/ortools/sat/cp_model_table.h
include/ortools/sat/cp_model_test_utils.h
include/ortools/sat/cp_model_utils.h
include/ortools/sat/cumulative.h
include/ortools/sat/cumulative_energy.h
@ -399,6 +486,7 @@ include/ortools/sat/feasibility_pump.h
include/ortools/sat/implied_bounds.h
include/ortools/sat/inclusion.h
include/ortools/sat/integer.h
include/ortools/sat/integer_base.h
include/ortools/sat/integer_expr.h
include/ortools/sat/integer_search.h
include/ortools/sat/intervals.h
@ -412,6 +500,7 @@ include/ortools/sat/linear_relaxation.h
include/ortools/sat/lp_utils.h
include/ortools/sat/max_hs.h
include/ortools/sat/model.h
include/ortools/sat/no_overlap_2d_helper.h
include/ortools/sat/opb_reader.h
include/ortools/sat/optimization.h
include/ortools/sat/parameters_validation.h
@ -421,6 +510,8 @@ include/ortools/sat/presolve_context.h
include/ortools/sat/presolve_util.h
include/ortools/sat/probing.h
include/ortools/sat/pseudo_costs.h
include/ortools/sat/python/linear_expr.h
include/ortools/sat/python/linear_expr_doc.h
include/ortools/sat/restart.h
include/ortools/sat/rins.h
include/ortools/sat/routing_cuts.h
@ -431,7 +522,10 @@ include/ortools/sat/sat_inprocessing.h
include/ortools/sat/sat_parameters.pb.h
include/ortools/sat/sat_solver.h
include/ortools/sat/scheduling_cuts.h
include/ortools/sat/scheduling_helpers.h
include/ortools/sat/shaving_solver.h
include/ortools/sat/simplification.h
include/ortools/sat/solution_crush.h
include/ortools/sat/stat_tables.h
include/ortools/sat/subsolver.h
include/ortools/sat/swig_helper.h
@ -451,20 +545,34 @@ include/ortools/scheduling/jobshop_scheduling.pb.h
include/ortools/scheduling/jobshop_scheduling_parser.h
include/ortools/scheduling/rcpsp.pb.h
include/ortools/scheduling/rcpsp_parser.h
include/ortools/set_cover/assignment.h
include/ortools/set_cover/capacity.pb.h
include/ortools/set_cover/capacity_invariant.h
include/ortools/set_cover/capacity_model.h
include/ortools/set_cover/set_cover.pb.h
include/ortools/set_cover/set_cover_heuristics.h
include/ortools/set_cover/set_cover_invariant.h
include/ortools/set_cover/set_cover_lagrangian.h
include/ortools/set_cover/set_cover_mip.h
include/ortools/set_cover/set_cover_model.h
include/ortools/set_cover/set_cover_reader.h
include/ortools/util/adaptative_parameter_value.h
include/ortools/util/affine_relation.h
include/ortools/util/aligned_memory.h
include/ortools/util/aligned_memory_internal.h
include/ortools/util/bitset.h
include/ortools/util/cached_log.h
include/ortools/util/dense_set.h
include/ortools/util/file_util.h
include/ortools/util/filelineiter.h
include/ortools/util/fixed_shape_binary_tree.h
include/ortools/util/flat_matrix.h
include/ortools/util/fp_roundtrip_conv.h
include/ortools/util/fp_roundtrip_conv_testing.h
include/ortools/util/fp_utils.h
include/ortools/util/functions_swig_helpers.h
include/ortools/util/functions_swig_test_helpers.h
include/ortools/util/graph_export.h
include/ortools/util/int128.pb.h
include/ortools/util/integer_pq.h
include/ortools/util/lazy_mutable_copy.h
include/ortools/util/logging.h
@ -485,6 +593,7 @@ include/ortools/util/rev.h
include/ortools/util/running_stat.h
include/ortools/util/saturated_arithmetic.h
include/ortools/util/sigint.h
include/ortools/util/solve_interrupter.h
include/ortools/util/sort.h
include/ortools/util/sorted_interval_list.h
include/ortools/util/stats.h
@ -495,43 +604,45 @@ include/ortools/util/strong_integers.h
include/ortools/util/testing_utils.h
include/ortools/util/time_limit.h
include/ortools/util/tuple_set.h
include/ortools/util/vector_map.h
include/ortools/util/vector_or_function.h
include/ortools/util/vector_sum.h
include/ortools/util/vector_sum_internal.h
include/ortools/util/zvector.h
include/ortools/xpress/environment.h
include/ortools_export.h
lib/cmake/ortools/modules/FindCbc.cmake
lib/cmake/ortools/modules/FindClp.cmake
lib/cmake/ortools/modules/FindEigen3.cmake
lib/cmake/ortools/modules/FindSCIP.cmake
lib/cmake/ortools/modules/Findre2.cmake
lib/cmake/ortools/ortoolsConfig.cmake
lib/cmake/ortools/ortoolsConfigVersion.cmake
lib/cmake/ortools/ortoolsTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/ortools/ortoolsTargets.cmake
lib/libortools.so
lib/libortools.so.9
lib/libortools.so.9.8.9999
lib/libortools.so.10
lib/libortools.so.10.0.9999
%%FLATZINC%%lib/libortools_flatzinc.so
%%FLATZINC%%lib/libortools_flatzinc.so.9
%%FLATZINC%%lib/libortools_flatzinc.so.9.8.9999
%%FLATZINC%%share/minizinc/cpsat/fzn_all_different_int.mzn
%%FLATZINC%%share/minizinc/cpsat/fzn_circuit.mzn
%%FLATZINC%%share/minizinc/cpsat/fzn_cumulative.mzn
%%FLATZINC%%share/minizinc/cpsat/fzn_cumulative_opt.mzn
%%FLATZINC%%share/minizinc/cpsat/fzn_diffn.mzn
%%FLATZINC%%share/minizinc/cpsat/fzn_diffn_nonstrict.mzn
%%FLATZINC%%share/minizinc/cpsat/fzn_disjunctive.mzn
%%FLATZINC%%share/minizinc/cpsat/fzn_disjunctive_opt.mzn
%%FLATZINC%%share/minizinc/cpsat/fzn_disjunctive_strict.mzn
%%FLATZINC%%share/minizinc/cpsat/fzn_disjunctive_strict_opt.mzn
%%FLATZINC%%share/minizinc/cpsat/fzn_inverse.mzn
%%FLATZINC%%share/minizinc/cpsat/fzn_network_flow.mzn
%%FLATZINC%%share/minizinc/cpsat/fzn_network_flow_cost.mzn
%%FLATZINC%%share/minizinc/cpsat/fzn_regular.mzn
%%FLATZINC%%share/minizinc/cpsat/fzn_subcircuit.mzn
%%FLATZINC%%share/minizinc/cpsat/fzn_table_bool.mzn
%%FLATZINC%%share/minizinc/cpsat/fzn_table_int.mzn
%%FLATZINC%%share/minizinc/cpsat/nostrings.mzn
%%FLATZINC%%share/minizinc/cpsat/redefinitions-2.0.mzn
%%FLATZINC%%share/minizinc/solvers/cpsat.msc
%%FLATZINC%%lib/libortools_flatzinc.so.10
%%FLATZINC%%lib/libortools_flatzinc.so.10.0.9999
%%FLATZINC%%share/minizinc/cp-sat/fzn_all_different_int.mzn
%%FLATZINC%%share/minizinc/cp-sat/fzn_circuit.mzn
%%FLATZINC%%share/minizinc/cp-sat/fzn_cumulative.mzn
%%FLATZINC%%share/minizinc/cp-sat/fzn_cumulative_opt.mzn
%%FLATZINC%%share/minizinc/cp-sat/fzn_diffn.mzn
%%FLATZINC%%share/minizinc/cp-sat/fzn_diffn_nonstrict.mzn
%%FLATZINC%%share/minizinc/cp-sat/fzn_disjunctive.mzn
%%FLATZINC%%share/minizinc/cp-sat/fzn_disjunctive_opt.mzn
%%FLATZINC%%share/minizinc/cp-sat/fzn_disjunctive_strict.mzn
%%FLATZINC%%share/minizinc/cp-sat/fzn_disjunctive_strict_opt.mzn
%%FLATZINC%%share/minizinc/cp-sat/fzn_inverse.mzn
%%FLATZINC%%share/minizinc/cp-sat/fzn_network_flow.mzn
%%FLATZINC%%share/minizinc/cp-sat/fzn_network_flow_cost.mzn
%%FLATZINC%%share/minizinc/cp-sat/fzn_regular.mzn
%%FLATZINC%%share/minizinc/cp-sat/fzn_subcircuit.mzn
%%FLATZINC%%share/minizinc/cp-sat/fzn_table_bool.mzn
%%FLATZINC%%share/minizinc/cp-sat/fzn_table_int.mzn
%%FLATZINC%%share/minizinc/cp-sat/nostrings.mzn
%%FLATZINC%%share/minizinc/cp-sat/redefinitions-2.0.2.mzn
%%FLATZINC%%share/minizinc/cp-sat/redefinitions-2.0.mzn
%%FLATZINC%%share/minizinc/solvers/cp-sat.msc