net/yaz: Fix build with ICU 76.1 and improve port

* Backport upstream commit 24bcca60b69b0ce162f63377e621de5cf53dcf76.patch
* Fix detection of newer versions of tcl
* Clean up port Makefile to follow Porters Handbook more closely

Reference:
https://github.com/indexdata/m4/pull/4

PR:		283564
Approved by:	portmgr (maintainer timeout, 3+ weeks)
This commit is contained in:
Daniel Engberg 2025-01-18 17:36:17 +01:00
parent bb0e915118
commit 48417960e9
3 changed files with 35 additions and 9 deletions

View File

@ -14,33 +14,37 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libicuuc.so:devel/icu \
libgnutls.so:security/gnutls
USES= gnome iconv libtool ncurses pathfix localbase:ldflags \
pkgconfig readline shebangfix tcl
USES= autoreconf gnome iconv libtool ncurses pathfix \
localbase:ldflags pkgconfig readline shebangfix tcl
SHEBANG_FILES= src/yaz-asncomp
GNU_CONFIGURE= yes
GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
USE_GNOME= libxml2 libxslt
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
CONFIGURE_ARGS= --enable-shared --with-iconv=${ICONV_PREFIX} \
--with-xml2 --with-xslt --with-icu --enable-tcpd
GNU_CONFIGURE= yes
LIBS+= -lexecinfo
PORTDOCS= *
CONFIGURE_ARGS= --enable-shared \
--enable-tcpd \
--with-iconv=${ICONV_PREFIX} \
--with-icu \
--with-xml2 \
--with-xslt
OPTIONS_DEFINE= DOCS MEMCACHED REDIS
MEMCACHED_DESC= Memcached distributed cache system support
MEMCACHED_CONFIGURE_WITH= memcached
MEMCACHED_LIB_DEPENDS= libmemcached.so:databases/libmemcached
REDIS_CONFIGURE_WITH= redis
REDIS_LIB_DEPENDS= libhiredis.so:databases/hiredis
post-patch:
@${REINPLACE_CMD} 's|tclsh |tclsh${TCL_VER} |' ${WRKSRC}/configure
post-configure:
@${REINPLACE_CMD} -e 's,[$$]{datarootdir}/man,${PREFIX}/share/man,' \
${WRKSRC}/doc/Makefile

View File

@ -0,0 +1,11 @@
--- configure.ac.orig 2025-01-04 19:57:47 UTC
+++ configure.ac
@@ -18,7 +18,7 @@ test -z "$YACC" && AC_MSG_WARN([GNU Bison not found])
AC_CHECK_PROGS([YACC], 'bison -y')
test -z "$YACC" -a ! -f src/cql.c && AC_MSG_ERROR([GNU Bison not found])
test -z "$YACC" && AC_MSG_WARN([GNU Bison not found])
-AC_CHECK_PROGS([TCLSH], [tclsh tclsh8.5 tclsh8.4 tclsh8.3 tclsh8.2], [tclsh])
+AC_CHECK_PROGS([TCLSH], [tclsh tclsh9.0 tclsh8.7 tclsh8.6 tclsh8.5 tclsh8.4 tclsh8.3 tclsh8.2], [tclsh])
AC_PROG_INSTALL
AM_PROG_LIBTOOL
AM_PROG_CC_C_O

View File

@ -0,0 +1,11 @@
--- m4/ac_check_icu.m4.orig 2021-12-02 14:20:48 UTC
+++ m4/ac_check_icu.m4
@@ -26,7 +26,7 @@ AC_DEFUN([AC_CHECK_ICU],
ICU_VERSION=`$pkgconfigpath --modversion icu-i18n`
ICU_CPPFLAGS=""
ICU_CFLAGS=`$pkgconfigpath --cflags icu-i18n`
- ICU_LIBS=`$pkgconfigpath --libs icu-i18n`
+ ICU_LIBS=`$pkgconfigpath --libs icu-i18n icu-uc`
else
AC_MSG_RESULT([not found])
fi