multimedia/libfame: Remove expired port

2024-12-31 multimedia/libfame: Obsolete library, last release in 2004. Consider migrating to multimedia/ffmpeg
This commit is contained in:
Rene Ladan 2025-03-02 12:46:27 +01:00
parent c0463bab7e
commit 3c8ba2f2e2
9 changed files with 1 additions and 276 deletions

1
MOVED
View File

@ -4189,3 +4189,4 @@ math/parmetis||2025-03-01|Has expired: Fails to fetch, unmaintained for years in
math/pspp||2025-03-01|Has expired: Listed as broken for more than 5 months
games/shaaft||2025-03-02|Has expired: Unmaintained upstream for ages, breaks with modern toolchains
devel/asmutils||2025-03-02|Has expired: latest upstream release is 19 years ago, replaced by a-Linux, does not build with GCC 14
multimedia/libfame||2025-03-02|Has expired: Obsolete library, last release in 2004. Consider migrating to multimedia/ffmpeg

View File

@ -168,7 +168,6 @@
SUBDIR += libdvdcss
SUBDIR += libdvdnav
SUBDIR += libdvdread
SUBDIR += libfame
SUBDIR += libgav1
SUBDIR += libhdhomerun
SUBDIR += libmatroska

View File

@ -1,39 +0,0 @@
PORTNAME= libfame
PORTVERSION= 0.9.1
PORTREVISION= 7
CATEGORIES= multimedia
MASTER_SITES= SF/fame/${PORTNAME}/${PORTVERSION}
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Video encoding library
WWW= https://fame.sourceforge.net/
LICENSE= LGPL20+
LICENSE_FILE= ${WRKSRC}/COPYING
DEPRECATED= Obsolete library, last release in 2004. Consider migrating to multimedia/ffmpeg
EXPIRATION_DATE=2024-12-31
USES= libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= MMX
OPTIONS_DEFAULT=MMX
MMX_CONFIGURE_ENABLE= mmx
.include <bsd.port.options.mk>
.if ${ARCH} == "i386"
MAKE_ARGS= CFLAGS="${CLFAGS}" CC="${CC}"
.endif
post-patch:
@${REINPLACE_CMD} \
-e 's|AC_DEFUN(AM_PATH_LIBFAME|AC_DEFUN([AM_PATH_LIBFAME]|g' \
${WRKSRC}/libfame.m4 ${WRKSRC}/libfame.m4.in
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (libfame-0.9.1.tar.gz) = 7b2c5b883db98e99476ae07bbf4f3aa91615e74a4d7fc918cb79154dd4fc08e1
SIZE (libfame-0.9.1.tar.gz) = 296837

View File

@ -1,12 +0,0 @@
--- configure Wed Feb 11 08:12:28 2004
+++ configure Tue Jul 12 18:56:00 2005
@@ -4500,4 +4500,9 @@
case "$target" in
+ *86-*-freebsd*)
+ CFLAGS="$CFLAGS -DHAS_BSWAP"
+ ;;
+ *-*-freebsd*)
+ ;;
alpha*-*-linux*)
if test x$ac_cv_c_compiler_gnu = xyes; then

View File

@ -1,11 +0,0 @@
--- src/half_mmx.h.orig 2002-04-30 22:04:02.000000000 +0400
+++ src/half_mmx.h 2014-12-01 01:08:04.000000000 +0300
@@ -18,7 +18,7 @@
*/
/**************************** half-pixel interpolation ***********************/
-static short const _mmx_one[] = { 1, 1, 1, 1 };
+short const _mmx_one[] = { 1, 1, 1, 1 };
static void inline mmx_interpolate(unsigned char **ref,
int pitch,

View File

@ -1,156 +0,0 @@
Some patches to fix compiler warnings...
-mi
The mpeg_close method only does anything, if MMX was used. Do not even
declare nor define it, if that is not the case.
--- src/fame_decoder_mpeg.c Tue Jul 1 04:59:34 2003
+++ src/fame_decoder_mpeg.c Tue Jul 12 19:02:15 2005
@@ -79,5 +79,7 @@
static void mpeg_interpolate(fame_decoder_t *decoder, int rounding);
static void mpeg_leave(fame_decoder_t *decoder);
+#ifdef HAS_MMX
static void mpeg_close(fame_decoder_t *decoder);
+#endif
FAME_CONSTRUCTOR(fame_decoder_mpeg_t)
@@ -91,5 +93,9 @@
FAME_DECODER(this)->interpolate = mpeg_interpolate;
FAME_DECODER(this)->leave = mpeg_leave;
+#ifdef HAS_MMX
FAME_DECODER(this)->close = mpeg_close;
+#else
+ FAME_DECODER(this)->close = NULL;
+#endif
return(this);
}
@@ -604,4 +610,5 @@
}
+#ifdef HAS_MMX
/* mpeg_close */
/* */
@@ -619,5 +626,4 @@
fame_decoder_mpeg_t *decoder_mpeg = FAME_DECODER_MPEG(decoder);
-#ifdef HAS_MMX
/* free mismatch accumulator */
{
@@ -627,4 +633,4 @@
fame_free(decoder_mpeg->mismatch_accumulator[i]);
}
-#endif
}
+#endif
Include the missing header:
--- src/fame_rate_simple.c Mon Apr 8 11:58:05 2002
+++ src/fame_rate_simple.c Tue Jul 12 19:05:27 2005
@@ -20,4 +20,5 @@
#include <stdio.h>
#include <stdlib.h>
+#include <string.h> /* strlen() */
#include <math.h>
#include "fame.h"
--- src/fame_rate_1param.c Sun May 12 14:34:45 2002
+++ src/fame_rate_1param.c Tue Jul 12 19:07:54 2005
@@ -20,4 +20,5 @@
#include <stdio.h>
#include <stdlib.h>
+#include <string.h> /* strlen() */
#include <math.h>
#include "fame.h"
--- src/mae_mmx.h Mon May 20 14:58:06 2002
+++ src/mae_mmx.h Tue Jul 12 19:22:34 2005
@@ -19,8 +19,8 @@
*/
-static unsigned int MAE8x8_withmask(unsigned char *ref,
- unsigned char *input,
- unsigned char *shape,
- int pitch)
+static inline unsigned int
+MAE8x8_withmask(unsigned char *ref, unsigned char *input,
+ unsigned char *shape,
+ int pitch)
{
int dummy;
@@ -71,8 +71,8 @@
}
-static unsigned int MAE8x8_withoutmask(unsigned char *ref,
- unsigned char *input,
- unsigned char *shape,
- int pitch)
+static inline unsigned int
+MAE8x8_withoutmask(unsigned char *ref, unsigned char *input,
+ unsigned char *shape,
+ int pitch)
{
int dummy;
--- src/mae_int.h Mon May 20 14:58:06 2002
+++ src/mae_int.h Tue Jul 12 19:24:06 2005
@@ -19,8 +19,8 @@
*/
-static unsigned int MAE8x8_withmask(unsigned char *ref,
- unsigned char *input,
- unsigned char *shape,
- int pitch)
+static inline unsigned int
+MAE8x8_withmask(unsigned char *ref, unsigned char *input,
+ unsigned char *shape,
+ int pitch)
{
int j,i;
@@ -42,8 +42,9 @@
}
-static unsigned int MAE8x8_withoutmask(unsigned char *ref,
- unsigned char *input,
- unsigned char *shape,
- int pitch)
+static inline unsigned int
+MAE8x8_withoutmask(unsigned char *ref,
+ unsigned char *input,
+ unsigned char *shape,
+ int pitch)
{
int j,i;
--- src/fame_motion_pmvfast.c Sat Oct 5 08:44:47 2002
+++ src/fame_motion_pmvfast.c Tue Jul 12 19:28:52 2005
@@ -20,4 +20,5 @@
#include <stdio.h>
#include <stdlib.h>
+#include <string.h> /* memcpy, memset */
#include "fame.h"
#include "fame_malloc.h"
@@ -922,5 +923,4 @@
fame_motion_vector_t *pvector_left, *pvector_topleft;
fame_motion_vector_t *pvector_top, *pvector_topright;
- unsigned int weight_left, weight_top, weight_topright;
unsigned char *shape;
--- src/fame_malloc.c Fri Jun 20 08:40:30 2003
+++ src/fame_malloc.c Tue Jul 12 19:59:14 2005
@@ -22,4 +22,6 @@
#include <stdlib.h>
+#include <stdio.h>
+#include <inttypes.h>
void* fame_malloc(size_t size)
@@ -37,7 +39,11 @@
ptr = (unsigned char*) malloc(size+ALIGN);
- aligned = (unsigned char*) (((unsigned int)ptr & (~(ALIGN-1))) + ALIGN );
+ if (ptr == NULL) {
+ perror("fame_malloc");
+ exit(1);
+ }
+ aligned = (unsigned char*) (((uintptr_t)ptr & (~(ALIGN-1))) + ALIGN );
padding = aligned - 1;
- *padding = (ALIGN-1) - ((unsigned int)ptr & (ALIGN-1));
+ *padding = (ALIGN-1) - ((uintptr_t)ptr & (ALIGN-1));
return ((void*)aligned);

View File

@ -1,13 +0,0 @@
libfame is a video encoding library.
It can currently encode MPEG-1 and MPEG-4 rectangular video, as well as
MPEG-4 video with arbitrary shape.
Objectives
- Compliance : Provide bitstreams compliant to the MPEG-1, MPEG-2 and
MPEG-4 video standards.
- Speed : Provide a fast implementation of the techniques used in MPEG
standards.
- Flexibility : Allow the user to choose between different options for
speed, compression ratio and quality.
- Portability : Support many different platforms and architectures.

View File

@ -1,42 +0,0 @@
bin/libfame-config
include/fame.h
include/fame_bitbuffer.h
include/fame_decoder.h
include/fame_decoder_mpeg.h
include/fame_encoder.h
include/fame_encoder_mpeg.h
include/fame_malloc.h
include/fame_monitor.h
include/fame_motion.h
include/fame_motion_fourstep.h
include/fame_motion_none.h
include/fame_motion_pmvfast.h
include/fame_profile.h
include/fame_profile_mpeg.h
include/fame_profile_mpeg1.h
include/fame_profile_mpeg4_shape.h
include/fame_profile_mpeg4_simple.h
include/fame_profile_stats.h
include/fame_rate.h
include/fame_rate_1param.h
include/fame_rate_simple.h
include/fame_shape.h
include/fame_syntax.h
include/fame_syntax_mpeg1.h
include/fame_syntax_mpeg4.h
include/fame_version.h
lib/libfame-0.9.so.1
lib/libfame-0.9.so.1.0.0
lib/libfame.a
lib/libfame.so
share/man/man3/fame_close.3.gz
share/man/man3/fame_encode_frame.3.gz
share/man/man3/fame_encode_slice.3.gz
share/man/man3/fame_end_frame.3.gz
share/man/man3/fame_get_object.3.gz
share/man/man3/fame_init.3.gz
share/man/man3/fame_open.3.gz
share/man/man3/fame_register.3.gz
share/man/man3/fame_start_frame.3.gz
share/man/man3/fame_unregister.3.gz
share/aclocal/libfame.m4